Obama Administration Mandates Bush Administration E-Verify Rule For Federal Contractors

July 8, 2009

Senate Still Passes Amendment With E-Verify

FOR IMMEDIATE RELEASE
CONTACT: (202) 675-2312; media@dcaclu.org

WASHINGTON - Department of Homeland Security Secretary Janet Napolitano and the U.S. Senate today both advanced a highly flawed electronic employee eligibility verification system. After multiple extensions delaying implementation of a Bush administration rule, Secretary Napolitano announced that federal contractors and subcontractors, including those receiving stimulus funds, would be required to use E-Verify starting September 8, 2009. Even after DHS’s announcement, the U.S. Senate passed a homeland security appropriations amendment that included a provision, sponsored by Senator Jeff Sessions (R-AL), mandating the use of E-Verify by federal contractors.

The following can be attributed to Joanne Lin, ACLU Legislative Counsel:

“Today’s DHS and Senate actions on E-Verify are bad news for millions of unemployed Americans and for struggling employers. In the middle of the toughest job market in decades, the Obama administration and the Senate have chosen to erect another roadblock to gainful employment for U.S. workers. The administration’s decision to expand E-Verify without correcting the defects in the database system will lead to unnecessary harm to U.S. workers. The Homeland Security and Social Security databases used by E-Verify have unacceptably high error rates involving U.S. citizens’ records. Expanding E-Verify to all federal contractors could lead to wrongful dismissals of U.S. workers. This flawed Bush-era policy, now adopted by the Obama administration, will only hurt the American workforce without improving our nation’s immigration enforcement practices.”

Statistics image